Stonebarrow Weekend

Previous Next

Stonebarrow Weekend
Stonebarrow Weekend
Fossil Hunting
World Cup Qualifiers
Quadbiking
Cerne Abbas Giant
Everyone’s appreciation to Serena for doing all the hard graft and to Mike for, well, just for being born as soon as he was!
Photos? - Ian, June, Simon/Liz?
Stonebarrow Manor, Charmouth, Dorset


Fossil Hunting

Previous Next

Stonebarrow Weekend : Fossil Hunting
Fossil Hunting
Simple as ABC:
•
Ammonites,
•
Belemnites,
and ...
•
Chucking it down!
Photos? - June, Simon/Liz?
Charmouth Fossils


World Cup Qualifiers

Previous Next

Stonebarrow Weekend : World Cup Qualifiers
World Cup Qualifiers
N.Ireland 2-3 Wales - “The dragon wakes ... only to find the party is over!”
England 1-0 Austria - “Berlin, 8th July 2006?... you’re having a laugh!”


Quadbiking

Previous Next

Stonebarrow Weekend : Quadbiking
Quadbiking
Photos? - June, Simon/Liz?
Henley Hillbillies


Cerne Abbas Giant

Previous Next

Stonebarrow Weekend : Cerne Abbas Giant
Cerne Abbas Giant
Photos? - June, Simon/Liz?
“Ever seen one as big as that before?!”
The Royal Oak
The Rude Man